Rose debug info
---------------

Подписка на блог

Customize in /user/extras/subscribe-sheet.tmpl.php.

Sample text.

Twitter, Facebook, VK, Telegram, LinkedIn, Odnoklassniki, Pinterest, РСС JSON Feed

Sample text.

Запрещаем перезагрузки и обновления

Пользователи Windows 10 знают, что эта система болт клала на желания пользователей и устанавливает обновление тогда, когда хочет. Но это еще цветочки и не несет проблемы, в отличие от ее желания внезапно взять и перезапуститься прям здесь и сейчас. И не важно, делается что-то на компьютере или он просто стоит запущенный. Вот нужно ей и хоть трава не расти.

Решение проблемы пришло в голову, когда стало понятно, что штатным способом запретить это полоумное поведение невозможно.
Идем на микрот и вбиваем в консоли следующий набор команд:

/ip firewall raw
add action=drop chain=prerouting comment="WSUS" protocol=tcp tls-host=windowsupdate.microsoft.com
add action=drop chain=prerouting comment="WSUS" protocol=tcp tls-host=download.microsoft.com
add action=drop chain=prerouting comment="WSUS" protocol=tcp tls-host=test.stats.update.microsoft.com
add action=drop chain=prerouting comment="WSUS" protocol=tcp tls-host=ntservicepack.microsoft.com
add action=drop chain=prerouting comment="WSUS" protocol=tcp tls-host=*.download.windowsupdate.com
add action=drop chain=prerouting comment="WSUS" protocol=tcp tls-host=*.update.microsoft.com
add action=drop chain=prerouting comment="WSUS" protocol=tcp tls-host=download.windowsupdate.com
add action=drop chain=prerouting comment="WSUS" protocol=tcp tls-host=*.windowsupdate.microsoft.com

/system scheduler
add name="WSUS_on" on-event="/ip firewall raw disable [find comment=\"WSUS\"]" start-date=Aug/12/2021 start-time=00:01:00 interval=7d comment="" disabled=no
add name="WSUS_off" on-event="/ip firewall raw enable [find comment=\"WSUS\"]" start-date=Aug/12/2021 start-time=00:08:00 interval=7d comment="" disabled=no

После этого, роутер заблокирует доступ до серверов обновлений майкрософта, но будет снимать их каждую неделю в четверг с часа ночи до восеми утра. В этот промежуток система сможет получить новые обновления и хоть заперезапускаться, сколько ей душе угодно.

Можете поменять время и период, если нужно в 2х последних командах (разобраться не сложно, синтаксис простой).

Подписаться на блог
Поделиться
Отправить
Отправить
1 мес   microsoft   mikrotik   network
1 комментарий
jablochniyvorishka 1 мес

довольно таки просто выглядит, но не понимаю ее надобность, ограничить сетевой трафик? установку обновления же можно отлаживать, виндовс уже не так жесток как ранее.

Ivan Tiukov 1 мес

Просто ситуация из жизни: я работаю на виртуалках. Одна из виртуалок лопатила проект 6 часов (итоговое время на сборку проекта — больше суток). Свернул удаленный доступ и занялся другими вещами. Все это время виртуалка лопатила на полную и подключение к ней было активно. И внезапно винда решила «а мне похрен» и ушла в ребут ставить обновления. И такое уже не первый раз.
Т. к. из винды выпилили возможность ставить обновления только вручную, едиснтвенный вариант — блокировать ей доступ до серверов обновлений и включать его только в определенное время. Таким образом, качать и ставить она их будет только по определенным дням.