Rose debug info
---------------

Подписка на блог

Customize in /user/extras/subscribe-sheet.tmpl.php.

Sample text.

Twitter, Facebook, VK, Telegram, LinkedIn, Odnoklassniki, Pinterest, РСС JSON Feed

Sample text.

Позднее Ctrl + ↑

Быстрое создание большого файла

Чтобы создать временный файл нужного размера, выполняем в консоли.

Для Linux:

fallocate -l 1G temp_file

Для Windows:

fsutil file createnew temp_file 1000000000

Для Mac OS X:

mkfile -n 1g temp_file
1 мес   admin   development   work

Божественная новость от Nvidia

Компания nvidia официально объявила о поддержке обычных десктопных и мобильных видеокарт в среде виртуализации. Да, теперь не нужны будут пляски вокруг KVM со скрытием от виртуалок того факта, что они виртуалки. А кроме того, теперь и на Xen можно будет использовать проброс видеокарт, т. к. ранее этого делать было невозможно в силу отсутствия возможности скрыть виртуализацию. Пока amd не может уже несколько поколений подряд пофиксить аппаратный баг с пробросом, nvidia делает такой прекрасный подгон для своих пользователей. Юху!

1 мес   admin   hardware   virtualization

От спасибо

От спасибо «любимому» правительству за полудурошные законы. Как же я жил то все это время без этого говна от российских компаний. Страдал, рыдал в подушку и грыз асфальт с горя. А теперь прям чувствую, как член увеличивается, небо голубеет и бабочки верхом на единорогах кругом.

1 мес   government   hate   phone

Mikrotik мониторим трафик

Если необходимо мониторить трафик роутера, то это можно сделать достаточно простым способом. Для этого нам понадобится собственно сам Mikrotik и Linux сервер с поднятым веб сервером, php и sqlite3.

Сначала идем на наш Linux сервер и создаем новую директорию tc для нашего сайтика со статистикой:

mkdir /var/www/html/tc

Затем даем права на запись в созданную директорию:

chmod 0777 /var/www/html/tc

Теперь скачиваем скрипт с генерацией статистики отсюда.

Распаковываем содержимое в созданную ранее директорию на Linux сервере и открываем на редактирование файл init.php.

В нем нужно поменять параметр, отвечающий за временную зону date_default_timezone_set на значение, которое вам необходимо. Список значений можно взять в официальном мануале тут.

Все. С сервером закончили. Статистика будет доступна по адресу http://SERVER_IP/tc/

Теперь идем настраивать микрот. Команды буду писать терминальные, т. к. мне тупо лень делать скриншоты графического интерфейса управления и расписывать там каждый шаг. Кому нужно, тот сам поймет, куда нужно тыкать мышкой.

Создаем правила фаервола, чтобы считать проходящий трафик через нужные интерфейсы:

/ip firewall mangle add chain=forward in-interface=bridge out-interface=ether1 action=passthrough comment=local-wan-tx
/ip firewall mangle add chain=forward in-interface=ether1 out-interface=bridge action=passthrough comment=local-wan-rx

В данном примере ether1 — интернет, bridge — локальная сеть. Меняете эти параметры на те, что используются у вас. Ограничений по типу разделения — нет, можете использовать и конкретные интерфейсы, и списки, и IP адреса или что вам больше удобно. Главное соблюдать логику.

Теперь создадим скрипт, который и будет генерировать статистику на сайте:

/system script
add dont-require-permissions=no name=tc owner=admin policy=\
ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source="/\
:local srvip "192.168.1.2";\r\
\n:local wantx "local-wan-tx";\r\
\n:local wanrx "local-wan-rx";\r\
\n:local sysname [/system identity get value-name=name];\r\
\n:local txbytes [/ip firewall mangle get [/ip firewall mangle find comment="$wantx"] bytes];\r\
\n:local rxbytes [/ip firewall mangle get [/ip firewall mangle find comment="$wanrx"] bytes];\r\
\n/tool fetch url=("http://$srvip/tc/collector.php\?sn=$sysname&tx=$txbytes&rx=$rxbytes") mode=http keep-result=no;\r\
\n/ip firewall mangle reset-counters [/ip firewall mangle find comment="$wantx"];\r\
\n/ip firewall mangle reset-counters [/ip firewall mangle find comment="$wanrx"];\r\
\n"

В данном скрипте необходимо сменить srvip на адрес вашего Linux сервера.

Теперь добавим запуск скрипта по таймеру:

/system scheduler add name="tc" interval=1h on-event=tc

На этом все. Для проверки работоспособности всей конструкции, можете или подождать час, или запустить скрипт вручную и перейти на наш сайтик и обновить страницу. Если все сделано верно, то страница обновится и появится статистика, разделенная по устройствам.

1 мес   admin   mikrotik   network
Ранее Ctrl + ↓